# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\((?=\S))|((?<=\S)\))"
test_str = ("blabla (text blabla)\n"
"blabla (100 text blabla 100)\n"
"blabla ( text blabla )\n"
"blabla ( text blabla )\n"
"blabla ( text blabla )\n"
"blabla ( text blabla )\n\n"
"Titel mit nur (einer öffnenden Klammer\n"
"Titel b) mit nur einer schliessenden Klammer\n"
"Titel c) und Titel d) ohne öffnende Klammer\n"
"Titel mit schliessender) Klammer vor (öffnender Klammer")
subst = "( "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.