using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\((?=\S))|((?<=\S)\))";
string substitution = @"( ";
string input = @"blabla (text blabla)
blabla (100 text blabla 100)
blabla ( text blabla )
blabla ( text blabla )
blabla ( text blabla )
blabla ( text blabla )
Titel mit nur (einer öffnenden Klammer
Titel b) mit nur einer schliessenden Klammer
Titel c) und Titel d) ohne öffnende Klammer
Titel mit schliessender) Klammer vor (öffnender Klammer";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}