$re = '/(\((?=\S))|((?<=\S)\))/m';
$str = 'blabla (text blabla)
blabla (100 text blabla 100)
blabla ( text blabla )
blabla ( text blabla )
blabla ( text blabla )
blabla ( text blabla )
Titel mit nur (einer öffnenden Klammer
Titel b) mit nur einer schliessenden Klammer
Titel c) und Titel d) ohne öffnende Klammer
Titel mit schliessender) Klammer vor (öffnender Klammer';
$subst = "( ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;