import Foundation
let pattern = #"(\((?=\S))|((?<=\S)\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
blabla (text blabla)
blabla (100 text blabla 100)
blabla ( text blabla )
blabla ( text blabla )
blabla ( text blabla )
blabla ( text blabla )
Titel mit nur (einer öffnenden Klammer
Titel b) mit nur einer schliessenden Klammer
Titel c) und Titel d) ohne öffnende Klammer
Titel mit schliessender) Klammer vor (öffnender Klammer
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"( "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)