const regex = /(\((?=\S))|((?<=\S)\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\((?=\\S))|((?<=\\S)\\))', 'gm')
const str = `blabla (text blabla)
blabla (100 text blabla 100)
blabla ( text blabla )
blabla ( text blabla )
blabla ( text blabla )
blabla ( text blabla )
Titel mit nur (einer öffnenden Klammer
Titel b) mit nur einer schliessenden Klammer
Titel c) und Titel d) ohne öffnende Klammer
Titel mit schliessender) Klammer vor (öffnender Klammer`;
const subst = `( `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);