#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\((?=\S))|((?<=\S)\))"
Local $sString = "blabla (text blabla)" & @CRLF & _
"blabla (100 text blabla 100)" & @CRLF & _
"blabla ( text blabla )" & @CRLF & _
"blabla ( text blabla )" & @CRLF & _
"blabla ( text blabla )" & @CRLF & _
"blabla ( text blabla )" & @CRLF & _
"" & @CRLF & _
"Titel mit nur (einer öffnenden Klammer" & @CRLF & _
"Titel b) mit nur einer schliessenden Klammer" & @CRLF & _
"Titel c) und Titel d) ohne öffnende Klammer" & @CRLF & _
"Titel mit schliessender) Klammer vor (öffnender Klammer"
Local $sSubst = "( "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)