# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(cla20.*)(\.h)/\U\1\E\2/gm;t' <<< "#include \"cla20ioh.h\"
#include \"cla20uth.h\"
#include \"cla20gch.h\"
#include \"cla20fnh.h\""