using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(cla20.*)(\.h)";
string substitution = @"\U\1\E\2";
string input = @"#include ""cla20ioh.h""
#include ""cla20uth.h""
#include ""cla20gch.h""
#include ""cla20fnh.h""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}