re = /(cla20.*)(\.h)/m
str = '#include "cla20ioh.h"
#include "cla20uth.h"
#include "cla20gch.h"
#include "cla20fnh.h"'
subst = '\\U\\1\\E\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result