const regex = /(cla20.*)(\.h)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(cla20.*)(\\.h)', 'gm')
const str = `#include "cla20ioh.h"
#include "cla20uth.h"
#include "cla20gch.h"
#include "cla20fnh.h"`;
const subst = `\U\1\E\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);