# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*?(?:_[^_r\n]*?(\d+)M)?$/$1/gm;t' <<< "A1M_PRE
AC2_0M
GA3_30M
DE3_1H30M"