import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?(?:_[^_r\\n]*?(\\d+)M)?$";
final String string = "A1M_PRE\n"
+ "AC2_0M\n"
+ "GA3_30M\n"
+ "DE3_1H30M";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}