// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*?(?:_[^_r\n]*?(\d+)M)?$").unwrap();
let string = "A1M_PRE
AC2_0M
GA3_30M
DE3_1H30M";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}