package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?(?:_[^_r\n]*?(\d+)M)?$`)
var str = `A1M_PRE
AC2_0M
GA3_30M
DE3_1H30M`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}