import Foundation
let pattern = #"^.*?(?:_[^_r\n]*?(\d+)M)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A1M_PRE
AC2_0M
GA3_30M
DE3_1H30M
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)