use strict;
my $str = 'A1M_PRE
AC2_0M
GA3_30M
DE3_1H30M';
my $regex = qr/^.*?(?:_[^_r\n]*?(\d+)M)?$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";