re = /^.*?(?:_[^_r\n]*?(\d+)M)?$/m
str = 'A1M_PRE
AC2_0M
GA3_30M
DE3_1H30M'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result