# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*?(?:_[^_r\n]*?(\d+)M)?$"
test_str = ("A1M_PRE\n"
"AC2_0M\n"
"GA3_30M\n"
"DE3_1H30M")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.