#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*?(?:_[^_r\n]*?(\d+)M)?$"
Local $sString = "A1M_PRE" & @CRLF & _
"AC2_0M" & @CRLF & _
"GA3_30M" & @CRLF & _
"DE3_1H30M"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)