using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?(?:_[^_r\n]*?(\d+)M)?$";
string substitution = @"$1";
string input = @"A1M_PRE
AC2_0M
GA3_30M
DE3_1H30M";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}