# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/mysql_real_escape_string\((.*?)\)/new_fun(\1)/gm;t' <<< "mysql_real_escape_string(parameter) "