// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)mysql_real_escape_string\((.*?)\)").unwrap();
let string = "mysql_real_escape_string(parameter) ";
let substitution = "new_fun(\\1)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}