use strict;
my $str = 'mysql_real_escape_string(parameter) ';
my $regex = qr/mysql_real_escape_string\((.*?)\)/mp;
my $subst = 'new_fun(\\1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";