#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)mysql_real_escape_string\((.*?)\)"
Local $sString = "mysql_real_escape_string(parameter) "
Local $sSubst = "new_fun(\1)"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)