$re = '/mysql_real_escape_string\((.*?)\)/m';
$str = 'mysql_real_escape_string(parameter) ';
$subst = "new_fun(\1)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;