const regex = /mysql_real_escape_string\((.*?)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('mysql_real_escape_string\\((.*?)\\)', 'gm')
const str = `mysql_real_escape_string(parameter) `;
const subst = `new_fun(\1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);