import Foundation
let pattern = #"mysql_real_escape_string\((.*?)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"mysql_real_escape_string(parameter) "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"new_fun(\1)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)