re = /mysql_real_escape_string\((.*?)\)/m
str = 'mysql_real_escape_string(parameter) '
subst = 'new_fun(\\1)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result