package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)mysql_real_escape_string\((.*?)\)`)
var str = `mysql_real_escape_string(parameter) `
var substitution = "new_fun(\1)"
fmt.Println(re.ReplaceAllString(str, substitution))
}