using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"mysql_real_escape_string\((.*?)\)";
string substitution = @"new_fun(\1)";
string input = @"mysql_real_escape_string(parameter) ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}