import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((<style>)|(<style type=.+)|(<\\/style>))";
final String string = "<style>\n"
+ " styles\n"
+ "</style>\n\n"
+ "<style type=\"text/css\">\n"
+ " styles\n"
+ "</style>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}