const regex = /((<style>)|(<style type=.+)|(<\/style>))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((<style>)|(<style type=.+)|(<\\\/style>))', 'g')
const str = `<style>
styles
</style>
<style type="text/css">
styles
</style>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);