import re
regex = re.compile(r"((<style>)|(<style type=.+)|(<\/style>))")
test_str = ("<style>\n"
" styles\n"
"</style>\n\n"
"<style type=\"text/css\">\n"
" styles\n"
"</style>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)