import Foundation
let pattern = #"((<style>)|(<style type=.+)|(<\/style>))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<style>
styles
</style>
<style type="text/css">
styles
</style>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)