use strict;
my $str = '<style>
styles
</style>
<style type="text/css">
styles
</style>';
my $regex = qr/((<style>)|(<style type=.+)|(<\/style>))/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";