#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bx((Not Met|Minimal|Met|Exceed|Outstanding)\b)"
Local $sString = ""xNot Met /Minimal /Met /Exceed /Outstanding "" & @CRLF & _
""/Not Met xMinimal /Met xExceed /Outstanding "" & @CRLF & _
""/Not Met /Minimal /Met /Exceed xOutstanding "" & @CRLF & _
""/Not Met /Minimal xMet /Exceed /Outstanding "" & @CRLF & _
"xMetx" & @CRLF & _
"jxNot Met"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")