import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bx((Not Met|Minimal|Met|Exceed|Outstanding)\\b)";
final String string = "\"xNot Met /Minimal /Met /Exceed /Outstanding \"\n"
+ "\"/Not Met xMinimal /Met xExceed /Outstanding \"\n"
+ "\"/Not Met /Minimal /Met /Exceed xOutstanding \"\n"
+ "\"/Not Met /Minimal xMet /Exceed /Outstanding \"\n"
+ "xMetx\n"
+ "jxNot Met";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}