using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bx((Not Met|Minimal|Met|Exceed|Outstanding)\b)";
string input = @"""xNot Met /Minimal /Met /Exceed /Outstanding ""
""/Not Met xMinimal /Met xExceed /Outstanding ""
""/Not Met /Minimal /Met /Exceed xOutstanding ""
""/Not Met /Minimal xMet /Exceed /Outstanding ""
xMetx
jxNot Met";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}