use strict;
my $str = '"xNot Met /Minimal /Met /Exceed /Outstanding "
"/Not Met xMinimal /Met xExceed /Outstanding "
"/Not Met /Minimal /Met /Exceed xOutstanding "
"/Not Met /Minimal xMet /Exceed /Outstanding "
xMetx
jxNot Met';
my $regex = qr/\bx((Not Met|Minimal|Met|Exceed|Outstanding)\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}