package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bx((Not Met|Minimal|Met|Exceed|Outstanding)\b)`)
var str = `"xNot Met /Minimal /Met /Exceed /Outstanding "
"/Not Met xMinimal /Met xExceed /Outstanding "
"/Not Met /Minimal /Met /Exceed xOutstanding "
"/Not Met /Minimal xMet /Exceed /Outstanding "
xMetx
jxNot Met`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}