// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bx((Not Met|Minimal|Met|Exceed|Outstanding)\b)").unwrap();
let string = "\"xNot Met /Minimal /Met /Exceed /Outstanding \"
\"/Not Met xMinimal /Met xExceed /Outstanding \"
\"/Not Met /Minimal /Met /Exceed xOutstanding \"
\"/Not Met /Minimal xMet /Exceed /Outstanding \"
xMetx
jxNot Met";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}