import Foundation
let pattern = #"\bx((Not Met|Minimal|Met|Exceed|Outstanding)\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
"xNot Met /Minimal /Met /Exceed /Outstanding "
"/Not Met xMinimal /Met xExceed /Outstanding "
"/Not Met /Minimal /Met /Exceed xOutstanding "
"/Not Met /Minimal xMet /Exceed /Outstanding "
xMetx
jxNot Met
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)