# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:.+?)(.{6}<em>.+?<\\/em>.{6})(?:.+)/...$1.../gm;t' <<< "шла Саша по шоссе и <em>сосала</em> сушку, или что-то другое"