// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:.+?)(.{6}<em>.+?<\/em>.{6})(?:.+)").unwrap();
let string = "шла Саша по шоссе и <em>сосала</em> сушку, или что-то другое";
let substitution = "...$1...";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}