use strict;
my $str = 'шла Саша по шоссе и <em>сосала</em> сушку, или что-то другое';
my $regex = qr/(?:.+?)(.{6}<em>.+?<\/em>.{6})(?:.+)/mp;
my $subst = '...$1...';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";