package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:.+?)(.{6}<em>.+?<\/em>.{6})(?:.+)`)
var str = `шла Саша по шоссе и <em>сосала</em> сушку, или что-то другое`
var substitution = "...$1..."
fmt.Println(re.ReplaceAllString(str, substitution))
}