const regex = /(?:.+?)(.{6}<em>.+?<\/em>.{6})(?:.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:.+?)(.{6}<em>.+?<\\\/em>.{6})(?:.+)', 'gm')
const str = `шла Саша по шоссе и <em>сосала</em> сушку, или что-то другое`;
const subst = `...$1...`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);