import Foundation
let pattern = #"(?:.+?)(.{6}<em>.+?<\/em>.{6})(?:.+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"шла Саша по шоссе и <em>сосала</em> сушку, или что-то другое"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"...$1..."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)