using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:.+?)(.{6}<em>.+?<\/em>.{6})(?:.+)";
string substitution = @"...$1...";
string input = @"шла Саша по шоссе и <em>сосала</em> сушку, или что-то другое";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}