$re = '/(?:.+?)(.{6}<em>.+?<\/em>.{6})(?:.+)/m';
$str = 'шла Саша по шоссе и <em>сосала</em> сушку, или что-то другое';
$subst = "...$1...";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;